华为设备配置命令

华为路由器配置命令表
计算机命令
~~~~~~~~~~
PCA login: root  ;使用 root 用户
password: linux  ;口令是 linux
# shutdown -h now  ;关机
# init 0  ;关机
# logout  ;用户注销
# login  ;用户登录
# ifconfig  ;显示 IP 地址
# ifconfig eth0 <ip address> netmask <netmask>  ;设置 IP 地址
# ifconfig eht0 <ip address> netmask <netmask> down  ;禁用 IP 地址
# route add 0.0.0.0 gw <ip>  ;设置网关
# route del 0.0.0.0 gw <ip>  ;删除网关
# route add default gw <ip>  ;设置网关
# route del default gw <ip>  ;删除网关
# route  ;显示网关
# ping <ip>  ;发 ECHO 包
# telnet <ip>  ;远程登录
----------------------------------------交换机命令
~~~~~~~~~~
[Quidway]dis cur  ;显示当前配置
[Quidway]display current-configuration  ;显示当前配置
[Quidway]display interfaces  ;显示接口信息
[Quidway]display vlan all  ;显示路由信息
[Quidway]display version  ;显示版本信息
[Quidway]super password  ;修改特权用户密码
[Quidway]sysname   ;交换机命名
[Quidway]interface ethernet 0/1  ;进入接口视图
[Quidway]interface vlan x  ;进入接口视图
[Quidway-Vlan-interfacex]ip address 10.65.1.1 255.255.0.0  ;配置 VLAN 的 IP 地址
[Quidway]ip route-static 0.0.0.0 0.0.0.0 10.65.1.2  ;静态路由=网关
[Quidway]rip  ;三层交换支持
[Quidway]local-user ftp

[Quidway]user-interface vty 0 4  ;进入虚拟终端
[S3026-ui-vty0-4]authentication-mode password  ;设置口令模式
[S3026-ui-vty0-4]set authentication-mode password simple 222  ;设置口令
[S3026-ui-vty0-4]user privilege level 3  ;用户级别
[Quidway]interface ethernet 0/1  ;进入端口模式
[Quidway]int e0/1  ;进入端口模式
[Quidway-Ethernet0/1]duplex {half|full|auto}  ;配置端口工作状态
[Quidway-Ethernet0/1]speed {10|100|auto}  ;配置端口工作速率
[Quidway-Ethernet0/1]flow-control  ;配置端口流控
[Quidway-Ethernet0/1]mdi {across|auto|normal}  ;配置端口平接扭接
[Quidway-Ethernet0/1]port link-type {trunk|access|hybrid}  ;设置端口工作模式
[Quidway-Ethernet0/1]port access vlan 3  ;当前端口加入到 VLAN
[Quidway-Ethernet0/2]port trunk permit vlan {ID|All}  ;设 trunk 允许的 VLAN
[Quidway-Ethernet0/3]port trunk pvid vlan 3  ;设置 trunk 端口的 PVID
[Quidway-Ethernet0/1]undo shutdown  ;激活端口
[Quidway-Ethernet0/1]shutdown  ;关闭端口
[Quidway-Ethernet0/1]quit  ;返回
[Quidway]vlan 3  ;创建 VLAN
[Quidway-vlan3]port ethernet 0/1  ;在 VLAN 中增加端口
[Quidway-vlan3]port e0/1  ;简写方式
[Quidway-vlan3]port ethernet 0/1 to ethernet 0/4  ;在 VLAN 中增加端口
[Quidway-vlan3]port e0/1 to e0/4  ;简写方式
[Quidway]monitor-port <interface_type interface_num>  ;指定镜像端口
[Quidway]port mirror <interface_type interface_num>  ;指定被镜像端口
[Quidway]port mirror int_list observing-port int_type int_num  ;指定镜像和被镜像
[Quidway]description string   ;指定 VLAN 描述字符
[Quidway]description   ;删除 VLAN 描述字
[Quidway]display vlan [vlan_id]   ;查看 VLAN 设置
[Quidway]stp {enable|disable}   ;设置生成树 ,默认关闭
[Quidway]stp priority 4096   ;设置交换机的优先级
[Quidway]stp root {primary|secondary}   ;设置为根或根的备份
[Quidway-Ethernet0/1]stp cost 200   ;设置交换机端口的花费
[Quidway]link-aggregation e0/1 to e0/4 ingress|both  ; 端口的聚合
[Quidway]undo link-aggregation e0/1|all   ; 始端口为通道号
[SwitchA-vlanx]isolate-user-vlan enable   ;设置主 vlan
[SwitchA]isolate-user-vlan <x> secondary <list>  ;设置主 vlan 包括的子 vlan
[Quidway-Ethernet0/2]port hybrid pvid vlan <id>  ;设置 vlan 的 pvid
[Quidway-Ethernet0/2]port hybrid pvid  ;删除 vlan 的 pvid
[Quidway-Ethernet0/2]port hybrid vlan vlan_id_list untagged ;设置无标识的 vlan 如果包的 vlan id 与 PVId 一致,则去掉 vlan 信息 . 默认 PVID=1 。所以设置 PVID 为所属 vlan id, 设置可以互通的 vlan 为 untagged.
----------------------------------------
路由器命令
~~~~~~~~~~
[Quidway]display version  ;显示版本信息
[Quidway]display current-configuration  ;显示当前配置
[Quidway]display interfaces  ;显示接口信息
[Quidway]display ip route  ;显示路由信息
[Quidway]sysname aabbcc  ;更改主机名
[Quidway]super passwrod 123456  ;设置口令
[Quidway]interface serial0  ;进入接口
[Quidway-serial0]ip address <ip> <mask|mask_len>  ;配置端口 IP 地址
[Quidway-serial0]undo shutdown  ;激活端口
[Quidway]link-protocol hdlc  ;绑定 hdlc 协议
[Quidway]user-interface vty 0 4
[Quidway-ui-vty0-4]authentication-mode password
[Quidway-ui-vty0-4]set authentication-mode password simple 222
[Quidway-ui-vty0-4]user privilege level 3
[Quidway-ui-vty0-4]quit
[Quidway]debugging hdlc all serial0  ;显示所有信息
[Quidway]debugging hdlc event serial0  ;调试事件信息 [Quidway]debugging hdlc packet serial0  ;显示包的信息
静态路由:
[Quidway]ip route-static <ip><mask>{interface number|nexthop}[value][reject|blackhole] 例如:
[Quidway]ip route-static 129.1.0.0 16 10.0.0.2
[Quidway]ip route-static 129.1.0.0 255.255.0.0 10.0.0.2
[Quidway]ip route-static 129.1.0.0 16 Serial 2
[Quidway]ip route-static 0.0.0.0 0.0.0.0  10.0.0.2
动态路由:
[Quidway]rip  ;设置动态路由
[Quidway]rip work  ;设置工作允许
[Quidway]rip input  ;设置入口允许
[Quidway]rip output  ;设置出口允许
[Quidway-rip]network 1.0.0.0  ;设置交换路由网络
[Quidway-rip]network all  ;设置与所有网络交换
[Quidway-rip]peer ip-address  ;
[Quidway-rip]summary  ;路由聚合
[Quidway]rip version 1  ;设置工作在版本 1
[Quidway]rip version 2 multicast  ;设版本 2,多播方式
[Quidway-Ethernet0]rip split-horizon  ;水平分隔
[Quidway]router id A.B.C.D  ;配置路由器的 ID
[Quidway]ospf enable  ;启动 OSPF 协议
[Quidway-ospf]import-route direct  ;引入直联路由
[Quidway-Serial0]ospf enable area <area_id>  ;配置 OSPF 区域
标准访问列表命令格式如下:
acl <acl-number> [match-order config|auto]  ;默认前者顺序匹配。
rule [normal|special]{permit|deny} [source source-addr source-wildcard|any] 例:
[Quidway]acl 10
[Quidway-acl-10]rule normal permit source 10.0.0.0 0.0.0.255
[Quidway-acl-10]rule normal deny source any
扩展访问控制列表配置命令配置 TCP/UDP 协议的扩展访问列表:
rule {normal|special}{permit|deny}{tcp|udp}source {<ip wild>|any}destination <ip wild>|any}
[operate]
配置 ICMP 协议的扩展访问列表:
rule {normal|special}{permit|deny}icmp source {<ip wild>|any]destination {<ip wild>|any]
[icmp-code] [logging]
扩展访问控制列表操作符的含义
equal portnumber  ;等于
greater-than portnumber  ;大于
less-than portnumber  ;小于
not-equal portnumber  ;不等
range portnumber1 portnumber2  ;区间
扩展访问控制列表举例
[Quidway]acl 101
[Quidway-acl-101]rule deny souce any destination any
[Quidway-acl-101]rule permit icmp source any destination any icmp-type echo
[Quidway-acl-101]rule permit icmp source any destination any icmp-type echo-reply
[Quidway]acl 102
[Quidway-acl-102]rule permit ip source 10.0.0.1 0.0.0.0 destination 202.0.0.1 0.0.0.0
[Quidway-acl-102]rule deny ip source any destination any
[Quidway]acl 103
[Quidway-acl-103]rule permit tcp source any destination 10.0.0.1 0.0.0.0 destination-port equal ftp
[Quidway-acl-103]rule  permit tcp source any destination 10.0.0.2 0.0.0.0 destination-port equal www
[Quidway]firewall enable
[Quidway]firewall default permit|deny
[Quidway]int e0
[Quidway-Ethernet0]firewall packet-filter 101 inbound|outbound
地址转换配置举例
[Quidway]firewall enable
[Quidway]firewall default permit
[Quidway]acl 101  ;内部指定主机可以进入 e0
[Quidway-acl-101]rule deny ip source any destination any
[Quidway-acl-101]rule permit ip source 129.38.1.1 0 destination any
[Quidway-acl-101]rule permit ip source 129.38.1.2 0 destination any
[Quidway-acl-101]rule permit ip source 129.38.1.3 0 destination any [Quidway-acl-101]rule permit ip source 129.38.1.4 0 destination any
[Quidway-acl-101]quit
[Quidway]int e0
[Quidway-Ethernet0]firewall packet-filter 101 inbound
[Quidway]acl 102 ;外部特定主机和大于 1024 端口的数据包允许进入 S0
[Quidway-acl-102]rule deny ip source any destination any
[Quidway-acl-102]rule permit tcp source 202.39.2.3 0 destination 202.38.160.1 0
[Quidway-acl-102]rule  permit tcp source any destination 202.38.160.1 0 destination-port great-than
1024
[Quidway-acl-102]quit
[Quidway]int s0
[Quidway-Serial0]firewall packet-filter 102 inbound  ;设 202.38.160.1 是路由器出口 IP。
[Quidway-Serial0]nat outbound 101 interface  ;是 Easy ip,将 acl 101 允许的 IP 从本接口出时变换源地址。
内部服务器地址转换配置命令 (静态 nat):
nat server global <ip> [port] inside <ip> port [protocol]  ;global_port 不写时使用 inside_port
[Quidway-Serial0]nat server global 202.38.160.1 inside 129.38.1.1 ftp tcp
[Quidway-Serial0]nat server global 202.38.160.1 inside 129.38.1.2 telnet tcp
[Quidway-Serial0]nat server global 202.38.160.1 inside 129.38.1.3 www tcp
设有公网 IP:202.38.160.101~202.38.160.103 可以使用。 ;对外访问 (原例题 )
[Quidway]nat address-group 202.38.160.101 202.38.160.103 pool1  ;建立地址池
[Quidway]acl 1
[Quidway-acl-1]rule permit source 10.110.10.0 0.0.0.255  ;指定允许的内部网络
[Quidway-acl-1]rule deny source any
[Quidway-acl-1]int serial 0
[Quidway-Serial0]nat outbound 1 address-group pool1  ;在 s0 口从地址池取出 IP
对外访问
[Quidway-Serial0]nat server global 202.38.160.101 inside 10.110.10.1 ftp tcp
[Quidway-Serial0]nat server global 202.38.160.102 inside 10.110.10.2 www tcp
[Quidway-Serial0]nat server global 202.38.160.102 8080 inside 10.110.10.3 www tcp
[Quidway-Serial0]nat server global 202.38.160.103 inside 10.110.10.4 smtp udp
PPP 设置:
[Quidway-s0]link-protocol ppp  ;默认的协议
PPP 验证:
主验方: pap|chap
[Quidway]local-user q2 password {simple|cipher} hello  ;路由器 1
[Quidway]interface serial 0
[Quidway-serial0]ppp authentication-mode {pap|chap}
[Quidway-serial0]ppp chap user q1  ;pap 时,没有此句
pap 被验方:
[Quidway]interface serial 0  ;路由器 2
[Quidway-serial0]ppp pap local-user q2 password {simple|cipher} hello
chap 被验方:
[Quidway]interface serial 0  ;路由器 2
[Quidway-serial0]ppp chap user q2  ;自己路由器名
[Quidway-serial0]local-user q1 password {simple|cipher} hello  ;对方路由器名
帧中继 frame-relay  (二分册 6-61)
[q1]fr switching
[q1]int s1
[q1-Serial1]ip address 192.168.34.51 255.255.255.0
[q1-Serial1]link-protocol fr  ;封装帧中继协议
[q1-Serial1]fr interface-type dce
[q1-Serial1]fr dlci 100
[q1-Serial1]fr inarp
[q1-Serial1]fr map ip 192.168.34.52 dlci 100
[q2]int s1
[q2-Serial1]ip address 192.168.34.52 255.255.255.0
[q2-Serial1]link-protocol fr
[q2-Serial1]fr interface-type dte
[q2-Serial1]fr dlci 100
[q2-Serial1]fr inarp
[q2-Serial1]fr map ip 192.168.34.51 dlci 100
帧中继监测
[q1]display fr lmi-info[]interface type number]
[q1]display fr map
[q1]display fr pvc-info[serial interface-number][dlci dlci-number]
[q1]display fr dlci-switch
[q1]display fr interface
[q1]reset fr inarp-info
[q1]debugging fr all[interface type number]
[q1]debugging fr arp[interface type number]
[q1]debugging fr event[interface type number]
[q1]debugging fr lmi[interface type number]
启动 ftp 服务:
[Quidway]local-user ftp password {simple|cipher} aaa service-type ftp
[Quidway]ftp server enable
---------------------------------------

暧昧贴

发表评论

    微笑 大笑 拽 大哭 奸笑 流汗 喷血 生气 囧 不爽 晕 示爱 卖萌 吃惊 迷离 爱你 吓死了 呵呵